Google Maps Start Problem bei Android Auto

Mercedes Sprinter 3 (Typ VS30, Baumuster W907/W910) - ab 2018
Antworten
Kurier66
Ist öfters hier
Ist öfters hier
Beiträge: 46
Registriert: 20 Mär 2018 14:33

Google Maps Start Problem bei Android Auto

Beitrag von Kurier66 »

Hallo,
in einem anderen Thread hab ich gestern mit @v-dulli gerätselt an was es liegen kann das bei mir im Sprinter im MBUX System über Android Auto Google Maps beim Start immer die ganze Verbindung abbricht und sich das Telefon neu verbinden will. Nun mach ich mal ein neues Thema auf da das sonst in dem anderen Thema untergeht.
Zuerst einmal ein paar Daten, wie gesagt es geht um das MBUX System im neuen Sprinter 907. Telefon ist ein Huawei P20, verbunden mit der USB C Dose vorn in der Ablage mit einem Original Kabel vom Mercedes Vertrieb.
Ich verbinde also das Handy mit dem System über Android Auto, es funktioniert alles einwandfrei, auch Telefonate. Wenn ich Google Maps öffne klappt auch das und ich kann über die manuelle sowie Spracheingabe ein neues Ziel auswählen. Die Route wird auch angezeigt, drücke ich nun auf Navigation starten bricht die Verbindung sofort ab und das Handy versucht sich ständig neu zu verbinden bis ich den Stecker ziehe. Es ist immer wieder das gleiche. Hat jemand einen Tip für mich an was das liegen könnte?
Benutzeravatar
bikeraper
Wohnt hier
Wohnt hier
Beiträge: 1687
Registriert: 15 Jun 2006 08:19
Wohnort: Berlin
Kontaktdaten:

Re: Google Maps Start Problem bei Android Auto

Beitrag von bikeraper »

Du nutzt also die Google Navigation und wenn Du dann auf die Mercedesnavigation umschaltest, dann nimmt Dir die Kiste das krumm? Verstehe ich das so richtig? Ich meine wenn ich das reproduzieren soll brauche ich den genauen Ablauf :-)
319er fahn muss man sich leisten können
Kurier66
Ist öfters hier
Ist öfters hier
Beiträge: 46
Registriert: 20 Mär 2018 14:33

Re: Google Maps Start Problem bei Android Auto

Beitrag von Kurier66 »

bikeraper hat geschrieben: 10 Feb 2020 14:51 Du nutzt also die Google Navigation und wenn Du dann auf die Mercedesnavigation umschaltest, dann nimmt Dir die Kiste das krumm? Verstehe ich das so richtig? Ich meine wenn ich das reproduzieren soll brauche ich den genauen Ablauf :-)
Hallo, nein, die Mercedes Navigation nutze und habe ich nicht. Ich hab ein Garmin an der Scheibe das reicht mir zu. Google Maps brauche ich ansonsten nur falls es das Ziel beim Garmin nicht gibt, kommt sehr selten vor und wenn dann meist nur im Ausland. Haupsächlich brauche ich Google Maps aber wegen den Verkehrsmeldungen, die sind da natürlich viel aktueller als im Garmin.
Achso, der genaue Ablauf.
Das Handy wird per USB Kabel verbunden das Auto gestartet. Im Normalfall startet Maps allein, ich sehe jetzt wo ich mich während der Fahrt befinde. In diesem Zustand funktioniert alles einwandfrei. Ich kann Anrufe annehmen oder selbst jemand anrufen. Auch kann ich Android Auto beenden und wieder Neuverbinden. Ich kann auch bei Maps ein Ziel suchen wenn ich es per Buchstaben eingebe oder über den Sprachbefehl. Maps zeigt mir dann die Route an und sobald ich auf den grünen Pfeil für Navigation starten klicke unterbricht die Verbindung und das Handy versucht eine neue Verbindung aufzubauen.
Ich hoffe das ist verstädlich genug, ich vermute ja das es etwas mit Goggle Maps zu tun hat da alles andere ja funktioniert.
Benutzeravatar
bikeraper
Wohnt hier
Wohnt hier
Beiträge: 1687
Registriert: 15 Jun 2006 08:19
Wohnort: Berlin
Kontaktdaten:

Re: Google Maps Start Problem bei Android Auto

Beitrag von bikeraper »

Ok, ich werde das mal bei mir versuchen und melde mich dann
319er fahn muss man sich leisten können
Benutzeravatar
bikeraper
Wohnt hier
Wohnt hier
Beiträge: 1687
Registriert: 15 Jun 2006 08:19
Wohnort: Berlin
Kontaktdaten:

Re: Google Maps Start Problem bei Android Auto

Beitrag von bikeraper »

Bei mir ist der Pfeil blau, was wohl egal ist, aber wenn ich da drauf tippe (auf dem MUX) startet die Navigation und es geht Alles, Habe mir sogar zwischendurch ne Whatsapp vorlesen lassen. Also mit nem S10 mit Android 10 keine Probleme
319er fahn muss man sich leisten können
Kurier66
Ist öfters hier
Ist öfters hier
Beiträge: 46
Registriert: 20 Mär 2018 14:33

Re: Google Maps Start Problem bei Android Auto

Beitrag von Kurier66 »

bikeraper hat geschrieben: 12 Feb 2020 11:34 Bei mir ist der Pfeil blau, was wohl egal ist, aber wenn ich da drauf tippe (auf dem MUX) startet die Navigation und es geht Alles, Habe mir sogar zwischendurch ne Whatsapp vorlesen lassen. Also mit nem S10 mit Android 10 keine Probleme
Erst mal Danke für deine Bemühungen, hast natürlich auch recht, der Pfeil ist blau.
Ich habe heute wieder probiert, hab AA gelöscht und wieder neu installiert. Hab auch das Handy deautorisiert und wieder neu verbunden. Hab bei Maps die Einstellungen konrolliert und auch bei Apps Maps alle Berechtigungen gegeben. Ich weiß mir einfach keinen Rat mehr, drück ich auf den blauen Pfeil bricht die Verbindung ab. Ohne MBUX, nur auf dem Handy funktioniert Google Maps wie gewohnt. Ich bin mit meinem Latain am Ende.
Kurier66
Ist öfters hier
Ist öfters hier
Beiträge: 46
Registriert: 20 Mär 2018 14:33

Re: Google Maps Start Problem bei Android Auto

Beitrag von Kurier66 »

Noch ein Nachtrag, ich habe es gerade noch mal mit einem anderen Handy, einem Sony Xperia, probiert. Da es einen anderen Anschluss hat habe ich natürlich auch ein anderes Kabel nehmen müssen, Ergebnis genau das gleiche, Abbruch der Verbindung bei Navigationsstart. Also kann ich Telefon und Kabel als Fehlerquelle schon fast ausschließen. Würde noch das MBUX selbst oder aber die Google Maps App bleiben. Dienstag hab ich noch einen Termin beim Händler, mal sehen ob da etwas raus kommt.
Benutzeravatar
bikeraper
Wohnt hier
Wohnt hier
Beiträge: 1687
Registriert: 15 Jun 2006 08:19
Wohnort: Berlin
Kontaktdaten:

Re: Google Maps Start Problem bei Android Auto

Beitrag von bikeraper »

Wenn es bei einem anderen Handy, mit anderer USB Leitung ebenfalls immer abbricht, bleibt ja nur das MUX als Fehlerquelle
319er fahn muss man sich leisten können
Kurier66
Ist öfters hier
Ist öfters hier
Beiträge: 46
Registriert: 20 Mär 2018 14:33

Re: Google Maps Start Problem bei Android Auto

Beitrag von Kurier66 »

bikeraper hat geschrieben: 18 Feb 2020 07:25 Wenn es bei einem anderen Handy, mit anderer USB Leitung ebenfalls immer abbricht, bleibt ja nur das MUX als Fehlerquelle
Das dachte ich auch, bei Daimler meinte man allerdings daß das Huawei P20 nicht auf der Kompatibilitätsliste steht, man was für ein Wort. Ich weiß zwar nicht was da groß anders sein soll als beim Huawei Mate 20, das steht aber auf der der Liste. Werde wenn ich dazu komme am WE einen weiteren Versuch mit einem Apfel Telefon unternehmen, mein Sohn hat so eins was laut Daimler kompertibel sein soll. Falls das auch nicht funktioniert bleibt wirklich nur noch das MBUX übrig.
Kurier66
Ist öfters hier
Ist öfters hier
Beiträge: 46
Registriert: 20 Mär 2018 14:33

Re: Google Maps Start Problem bei Android Auto

Beitrag von Kurier66 »

Hab heute den Apfel mit dem Systen verbunden und was soll ich sagen, es funktionierte. Da scheint es wirklich an meinem P20 zu liegen. :? :?
Da werde ich wohl wenn es ein neues Handy gibt eines nehmen müssen was laut Mercedes kompatibel ist. :roll:
jense
Wohnt hier
Wohnt hier
Beiträge: 2986
Registriert: 09 Jun 2008 20:46

Re: Google Maps Start Problem bei Android Auto

Beitrag von jense »

android auto sollte doch eigentlich mit allen handys funktionieren, die das unterstützen ... komische Geschichte...
Crafter 30, 2014, kurz und hoch, 136 PS BMT, Multivan XL mit WoMo-Zulassung und 2-5 Sitzplätzen (Lübeck)

BIETE linke ARMLEHNE in schwarz für ISRI Seriensitze. Interesse? PN!
Kurier66
Ist öfters hier
Ist öfters hier
Beiträge: 46
Registriert: 20 Mär 2018 14:33

Re: Google Maps Start Problem bei Android Auto

Beitrag von Kurier66 »

jense hat geschrieben: 23 Feb 2020 19:47 android auto sollte doch eigentlich mit allen handys funktionieren, die das unterstützen ... komische Geschichte...
Als Bedingung für Android Auto wird ja auich nur genannt das Android 5 oder höher auf dem Handy installiert sein soll, da ich 9.0 habe müsste es ja theoretisch gehen. Außerdem hat der freundliche wohl diese https://www.mercedes-benz-mobile.com/de ... finder/~bt Liste genommen, die ist aber für die A Klasse, eine andere finde ich nicht.
gianellasandro
Ganz neu hier
Ganz neu hier
Beiträge: 6
Registriert: 08 Jun 2020 12:23

Re: Google Maps Start Problem bei Android Auto

Beitrag von gianellasandro »

Hallo erstmal!

Ich habe einen neuen Sprinter mit MBUX und ein Google Pixel 3 und genau dasselbe Problem, welches du beschreibst. Also funktioniert alles wunderbar (mit Kabel verbunden) bis ich anfange zu navigieren über Google Maps, dann bricht er nach 3 Sekunden ab und schmeisst das Handy raus.

Hast du es mittlerweile auch mit einem Android Handy geschafft? Hat jemand sonst noch das Problem und einen Ausweg gefunden?
Kurier66
Ist öfters hier
Ist öfters hier
Beiträge: 46
Registriert: 20 Mär 2018 14:33

Re: Google Maps Start Problem bei Android Auto

Beitrag von Kurier66 »

gianellasandro hat geschrieben: 24 Aug 2020 13:50 Hallo erstmal!

Ich habe einen neuen Sprinter mit MBUX und ein Google Pixel 3 und genau dasselbe Problem, welches du beschreibst. Also funktioniert alles wunderbar (mit Kabel verbunden) bis ich anfange zu navigieren über Google Maps, dann bricht er nach 3 Sekunden ab und schmeisst das Handy raus.

Hast du es mittlerweile auch mit einem Android Handy geschafft? Hat jemand sonst noch das Problem und einen Ausweg gefunden?
Hallo gianellasandro
Nein, ich habe es leider nicht geschafft ein Android Handy zu finden mit dem es funktioniert :evil:
Allerdings habe ich mir im Juni Notgedrungen ein IPhone zugelegt nachdem mein Vertrag verlängert werden konnte. Notgedrungen deshalb weil ich kein Freund dieses Apfel Zeugs bin, alles ist anders wie man es Jahrelang gewohnt war, teils auch viel umständlicher. ABER EGAL, es funktioniert wenigstens in Verbindung mit dem MBUX, das war der Hauptgrund mir eins zuzulegen. Ob ich das Handy verbunden lasse beim Kunden oder mitnehme und dann im Auto wieder anschließe. Keine Probleme mehr ob mit Google Maps oder Waze, funktioniert alles Top.
Da ich nun kein Android Handy mehr in Gebrauch habe, hab ich mich selbstverständlich auch nicht mehr darum gekümmert warum es nicht funktioniert. Mittlerweile bin ich aber fast überzeugt das es am MBUX liegt, vielleicht müsste mal ein update gemacht werden :?:

PS. Ich wäre trotzdem gespannt ob es mittlerweile eine Lösung dieses Problems gibt.
Antworten