SD Karte wird nicht vom APS COMAND gelesen

Mercedes Sprinter 2 (Typ NCV3, Baumuster W906) & VW Crafter 1 - ab 2006 bis 2017 bzw. 2018
Antworten
Benutzeravatar
trcolka
Kennt sich schon aus
Kennt sich schon aus
Beiträge: 58
Registriert: 19 Apr 2019 22:01
Wohnort: Örebro

Fahrerkarte

SD Karte wird nicht vom APS COMAND gelesen

Beitrag von trcolka »

Hallo,

mein APS COMAND ist nicht gerade in Höchstform.
Navigation zeigt nicht die korrekte Position an, statt mitten in Schweden wähnt sich das GPS irgendwo im Atlantik westlich von Norwegen. Ist eher unwichtig, ich navigiere eh per Telefon.
CD-Spieler geht nicht, CD's rotieren eine Weile nach Einlegen, werden dann aber nicht erkannt. DVD's auch nicht. Damit kann/könnte ich leben, Speicherkarte (bzw. kopieren auf die interne Festplatte des APS COMAND) ist/wäre eh bequemer.

Aber der Kartenleser für die SD-Karte will auch nicht, und das ist schon schade/nervend.

Ich hab ein wenig gegoogelt, es gab (mindestens) ein Firmwareupdate. Kontrolliert, ich habe die neueste Firmware.
Da sollten jetzt sogar SD-HC Karten gehen. Das war vorher wohl problematisch. Ausserdem soll es eine gewisse Streuung geben, was die Kartenmodelle angeht, manche Hersteller gehen, manche nicht.

Ich hab jetzt mit unterschiedlichen Karten probiert, 2 Stück davon waren Sandisk (also Markenware) mit 2 Gbyte (also das einfachste vom einfachen, kein SD-HC oder so), mit Standard FAT formartiert, wenige mp3-Dateien auf der Karte, sowohl direkt im Wurzelverzeichnis als auch in einem Ordner. Alles mit kurzen 8.3 Dateinamen (aus uralt-DOS Zeiten) um solche Fehler auschliessen zu können.

Das Radio erkennt, dass eine Karte eingelegt ist, es meckert nämlich, wenn ich die Karte wieder rausnehme. Es werden aber einfach keine Dateien/Musikstücke bei eingelegter Karte angezeigt. Und ich bin im richtigen Menü des Radios, die Bedienung ist da nicht so kompliziert.

Hat jemand noch eine Idee, was ich testen kann? Mir fällt nämlich nichts mehr ein.

Und ja, FM-Radio und Telefonanbindung funktionieren, Gerät ist also im Prinzip funktionionsfähig.

Fahrzeugdaten:
316 NTG von 2011, mit APS COMAND halt :D Gemäss Internet-Recherche ist das ein APS COMAND NTG2.5

Grüsse aus Schweden
Olaf
316 NGT, Automatik, Bj. 2011, 9 Sitze, Hochdach

Benutzeravatar
Vanagaudi
Wohnt hier
Wohnt hier
Beiträge: 2960
Registriert: 18 Mai 2013 14:34
Wohnort: Schlootkuhlen

Galerie

Re: SD Karte wird nicht vom APS COMAND gelesen

Beitrag von Vanagaudi »

Das mit dem GPS habe ich gerade mit einer Ersatz-GPS-Antenne gelöst. Vermutlich ist bei mir der Verstärker in der Antenne gestorben.

CD/DVD spielen in Fahrzeugen oft nicht, weil die Linse verdreckt ist. Also reinigen oder austauschen.

Bezüglich der SD-Karte, wie ist der Allgemeinzustand des Geräts? Kann da Dreck auf den Kontakten liegen? Ansonsten hast du dich da schon gut informiert und einige Fehlerquellen ausgeschlossen.

Sind deine Fehler alle nach-und-nach aufgetaucht? Ansonsten würde ich eventuell auf einen Fehler in der Spannungsversorgung innerhalb des Geräts tippen.
Für (Folge-) Schäden aller Art übernehme ich keine Haftung. Alle einschlägigen (Sicherheits-) Vorschriften sind zu beachten. Im Zweifelsfalle grundsätzlich einen Fachmann fragen bzw. die Arbeiten von einer Fachfirma ausführen lassen.

Benutzeravatar
trcolka
Kennt sich schon aus
Kennt sich schon aus
Beiträge: 58
Registriert: 19 Apr 2019 22:01
Wohnort: Örebro

Fahrerkarte

Re: SD Karte wird nicht vom APS COMAND gelesen

Beitrag von trcolka »

Hallo,

vielen Dank für die schnelle und ausführliche Antwort.
Vanagaudi hat geschrieben:
23 Mär 2020 11:28
Das mit dem GPS habe ich gerade mit einer Ersatz-GPS-Antenne gelöst. Vermutlich ist bei mir der Verstärker in der Antenne gestorben.
Ich habe ja ein GPS Signal. Als ich mal verreist mal, war der falsche Standort im Navi plötzlich über Land, da konnte ich sehen, dass sich das Signal bewegt. Ist aber wie gesagt nicht so wichtig, da werde ich mich jetzt nicht weiter drum kümmern.
Vanagaudi hat geschrieben:
23 Mär 2020 11:28
CD/DVD spielen in Fahrzeugen oft nicht, weil die Linse verdreckt ist. Also reinigen oder austauschen.
Das klingt nach einer möglichen Ursache. Wenn ich eine CD einlege rotiert sie ja eine Weile, der Motor ist also soweit in Ordnung, der Spieler scheint aber "nicht den Anfang zu finden".
Kommt man denn an die Linse ran? Da muss dann wohl das ganze Radio aus- und auseinanderbauen nehme ich mal an.
Gibt es denn diese Linse als Ersatzteil? Schnelles Googeln hat mich da nicht weitergebracht.
Vanagaudi hat geschrieben:
23 Mär 2020 11:28
Bezüglich der SD-Karte, wie ist der Allgemeinzustand des Geräts? Kann da Dreck auf den Kontakten liegen?
Das mit Dreck auf den Kontakten ist eine gute Idee! Darauf bin ich noch nicht gekommen. Der Sprinter ist ja von 2011 und hat schon fast 300 tkm hinter sich, da kann sich im Laufe der Jahre fast angesammelt haben. Vorher war der Sprinter Taxi (also kein Hantwerkerfahrzeug), das Radio ist allgemein (Knöpfe und so) im guten Zustand, wurde vermutlich normal behandelt.

Die Kontakte sollten ja nicht zu tief drin liegen, so eine SD Karte ist ja nicht so gross, das werde ich mal mit Kontaktspray bearbeiten.
Vanagaudi hat geschrieben:
23 Mär 2020 11:28
Sind deine Fehler alle nach-und-nach aufgetaucht? Ansonsten würde ich eventuell auf einen Fehler in der Spannungsversorgung innerhalb des Geräts tippen.
Fehler waren alle so da, als ich das Auto im August 2019 gekauft hab. Bildschirm funktioniert, der Motor des CD-Spielers, Speicherkarte eingelegt/nicht eingelegt wird erkannt. Bluetooth zum Telefon funktioniert auch. Mein Gefühl sagt mir, dass die Spannungsversorgung soweit in Ordnung ist. 100% sicher kann ich das natürlich nicht sagen.

Grüsse aus Schweden
Olaf
316 NGT, Automatik, Bj. 2011, 9 Sitze, Hochdach

hljube
Fühlt sich wie zu Hause
Fühlt sich wie zu Hause
Beiträge: 427
Registriert: 27 Feb 2017 19:52
Wohnort: Lübeck

Galerie

Re: SD Karte wird nicht vom APS COMAND gelesen

Beitrag von hljube »

Zum CD Laufwerk:
Bevor du das gesamte Radio zerlegst, versuch es doch erstmal mit ner "Reinigungs CD".
kostet so um die 5€ hier auf Amazon.
Wenn es danach nicht geht, kann man ja immer noch alles auseinander schrauben.
MFG
Julian

-1988er T3 1.6TD (RIP)
-2012er W906 313 L2H1

Benutzeravatar
Vanagaudi
Wohnt hier
Wohnt hier
Beiträge: 2960
Registriert: 18 Mai 2013 14:34
Wohnort: Schlootkuhlen

Galerie

Re: SD Karte wird nicht vom APS COMAND gelesen

Beitrag von Vanagaudi »

Eigentlich tauscht man gleich das ganze Laufwerk aus. Kostet zwischen 5 und 20 Euro auf einer fernöstlichen Handelsplattform.

Anstatt einer Reinigungs-CD kauft man sich besser eine Dose Druckluft oder geht in die Werkstatt und pustet das Gerät mit Druckluft aus. Was soll so eine CD reinigen? Das ist alles kontaktlos mit relativ großem Luftspalt.
Für (Folge-) Schäden aller Art übernehme ich keine Haftung. Alle einschlägigen (Sicherheits-) Vorschriften sind zu beachten. Im Zweifelsfalle grundsätzlich einen Fachmann fragen bzw. die Arbeiten von einer Fachfirma ausführen lassen.

Benutzeravatar
Fachmann
Fast schon Admin
Fast schon Admin
Beiträge: 1316
Registriert: 08 Sep 2007 19:41

Re: SD Karte wird nicht vom APS COMAND gelesen

Beitrag von Fachmann »

Die Linse mit einer Bürste die an der Reinigungs CD dran ist...

Ist für die Einzugslaufwerke aber nicht so gut. Kann hängen bleiben. Da ist das mit der Luft schon besser aber man muss schon wissen wohin man pustet und mit wie viel Druck. Sonst macht man noch mehr kaputt.

Benutzeravatar
Vanagaudi
Wohnt hier
Wohnt hier
Beiträge: 2960
Registriert: 18 Mai 2013 14:34
Wohnort: Schlootkuhlen

Galerie

Re: SD Karte wird nicht vom APS COMAND gelesen

Beitrag von Vanagaudi »

Wenn man sich aber vor Augen führt, dass die Linse zur Fokussierung auf einer kleinen Spule freischwebend in einem Magnetfeld hängt (ähnlich wie bei einem Lautsprecher), dann möchte man da sicher nicht mit einer Bürste drüber gehen.
Für (Folge-) Schäden aller Art übernehme ich keine Haftung. Alle einschlägigen (Sicherheits-) Vorschriften sind zu beachten. Im Zweifelsfalle grundsätzlich einen Fachmann fragen bzw. die Arbeiten von einer Fachfirma ausführen lassen.

Benutzeravatar
Sprinter_213_CDI
Fast schon Admin
Fast schon Admin
Beiträge: 1233
Registriert: 08 Feb 2012 21:47
Wohnort: Berlin

Galerie
Fahrerkarte

Re: SD Karte wird nicht vom APS COMAND gelesen

Beitrag von Sprinter_213_CDI »

trcolka hat geschrieben:
23 Mär 2020 10:58
... mein APS COMAND ist nicht gerade in Höchstform.
Hallo
Schon mal die Spannung gemessen ?
Wie alt ist das Fzg. ?
MfG
Bj. Juli / 2010, 161.000 km

Rückfahrkamera, C Schienen, 2DIN Radio, 4 x 100 Ah Batterien, Sitzbank 3 - 5, Drehsitze, zwei Airbag, AHK, Tempomat mit Limiter, WR 1500 W, Ladebooster WA 121525 , Airtronic 3900, 390W Solar mit MPPT, 2. Kupplung

Benutzeravatar
trcolka
Kennt sich schon aus
Kennt sich schon aus
Beiträge: 58
Registriert: 19 Apr 2019 22:01
Wohnort: Örebro

Fahrerkarte

Re: SD Karte wird nicht vom APS COMAND gelesen

Beitrag von trcolka »

Vielen Dank für die ganzen Antworten.

Heute vormittag wollte ich eigentlich nur den Kartenleser im eingebauten Zustand zu reinigen: Staubsauger, Druckluft, Kontaktspray war angedacht. Nach Staubsauger (jetzt ist wenigstens auch das ganze Auto gesaugt...) fiel mir aber auf, wie leicht die Plastikverkleidung am Radio abzunehmen ist, da ist ja netterweise eine kleine Auspaurung drin, an der man bequem hebeln kann.

Und das Radio ist ja auch nur mit 4 Schrauben befestigt...lange Rede, kurzer Sinn, jetzt liegt das Radio komplett zerlegt im Keller :D

Der Kartenleser sieht so aus:
20200328_114049.jpg
20200328_121924.jpg
Die Kontakte sehen eigentlich in Ordung aus, auch Position und Höhe scheinen so zu stimmen, ich habe probeweise mal eine SD-Karte reingeschoben/gegengehalten.
Jetzt hab die Kontakte nochmal mit Kontaktreiniger eingesprüht.

Und wenn ich nun schon mal dabei war, wurde der CD-Spieler auch gleich ausgebaut.
20200328_121057.jpg
Die Linse hab ich gefunden. Auf der Kontaktreinigerdose steht "spurenfrei für alle Oberflächen", also hat die Linse auch was davon abgekommen, sollte das die Linse endgültig versaut haben, ist es auch nicht so schlimm.

Im allgemeinen war aber im Radio drin alles schön sauber und staubfrei.

Der Reiniger durfte über die Mittagspause verdunsten, jetzt werde ich mich mal ans Zusammenbauen machen. Ich hoffe, dass ich jetzt nicht irgendeinen Code oder so eingeben muss, wenn man Radio wieder eingebaut wird, darüber hatte ich mir keinen Kopf gemacht beim Ausbauen.

Gibt es eigentlich die Einzelteile (wie z.B. den Kartenleser) auch einzeln zu kaufen? Tipps wo ich sowas finden kann, werden dankbar entgegen genommen.

Wochenendgrüsse aus Schweden
Olaf
316 NGT, Automatik, Bj. 2011, 9 Sitze, Hochdach

Benutzeravatar
trcolka
Kennt sich schon aus
Kennt sich schon aus
Beiträge: 58
Registriert: 19 Apr 2019 22:01
Wohnort: Örebro

Fahrerkarte

Re: SD Karte wird nicht vom APS COMAND gelesen

Beitrag von trcolka »

Sprinter_213_CDI hat geschrieben:
23 Mär 2020 23:15
trcolka hat geschrieben:
23 Mär 2020 10:58
... mein APS COMAND ist nicht gerade in Höchstform.
Hallo
Schon mal die Spannung gemessen ?
Wie alt ist das Fzg. ?
MfG
Sprinter ist von 2011, aber halt schon 294 tkm.
Spannung hab ich jetzt nicht gemessen, Radio im allgemeinen (Farbbildschirm, CD-Motor) funktioniert ja.

Grüsse an meine Heimatstadt Berlin :D
Olaf
316 NGT, Automatik, Bj. 2011, 9 Sitze, Hochdach

Benutzeravatar
Vanagaudi
Wohnt hier
Wohnt hier
Beiträge: 2960
Registriert: 18 Mai 2013 14:34
Wohnort: Schlootkuhlen

Galerie

Re: SD Karte wird nicht vom APS COMAND gelesen

Beitrag von Vanagaudi »

trcolka hat geschrieben:
28 Mär 2020 14:13
jetzt liegt das Radio komplett zerlegt im Keller :D
Hast du mal ein paar Detailaufnahmen von den Kontaktzungen für den SD-Kartenhalter? Die sind kaum zu erkennen. Sind sie alle gleich hoch?

Die SD-Kartenaufnahme kannst du als Einzelteil bekommen. Aber ich weiß nicht, ob du die Möglichkeit hast, den Halter auszutauschen.

Hast du noch eine Übersichtsaufnahme von dem ganzen CD-Spieler, von beiden Seiten? Dann könnte man den Hersteller und den Ersatztyp identifizieren.

Update:
Das könnte ein DVD-Abspieler von Alpine sein, Typ DV43M050, DV43M870, DV43M07B oder DV43M. Wird bei Mercedes NTG2.5 Navigationssysteme eingesetzt. Das Ding kostet aber seine 125 Euro. Die Baueinheit mit dem Laser ED21A710 kostet allerdings nur 15 Euro. Ist also überschaubar.
Für (Folge-) Schäden aller Art übernehme ich keine Haftung. Alle einschlägigen (Sicherheits-) Vorschriften sind zu beachten. Im Zweifelsfalle grundsätzlich einen Fachmann fragen bzw. die Arbeiten von einer Fachfirma ausführen lassen.

Benutzeravatar
trcolka
Kennt sich schon aus
Kennt sich schon aus
Beiträge: 58
Registriert: 19 Apr 2019 22:01
Wohnort: Örebro

Fahrerkarte

Re: SD Karte wird nicht vom APS COMAND gelesen

Beitrag von trcolka »

Vanagaudi hat geschrieben:
28 Mär 2020 15:25
Hast du mal ein paar Detailaufnahmen von den Kontaktzungen für den SD-Kartenhalter? Die sind kaum zu erkennen. Sind sie alle gleich hoch?
20200328_121918_zungen.jpg
Die waren alle halbwegs gleich hoch, kommt auf dem Bild nicht so gut rüber. Kontakt sollte da eigentlich bestehen.

Radio ist wieder zusammengebaut, wird gleich wieder in den Sprinter verpflanzt. Die Sperrklinke für den Kartenleser hab ich auch nach vielen Versuchen nicht wieder zum Funktionieren bekommen. Hab sie dann weggelassen. Jetzt kann ich die SD-Karten ziemlich tief reinstecken. Dann muss man sie aber mit einem kleinen Schraubenzieher wieder rauspulen :|

Vanagaudi hat geschrieben:
28 Mär 2020 15:25
Die SD-Kartenaufnahme kannst du als Einzelteil bekommen. Aber ich weiß nicht, ob du die Möglichkeit hast, den Halter auszutauschen.
Fein. Wo denn? Bei Mercedes doch wohl eher nicht nehme ich mal an, die betrachten das Radio doch vermutlich als ganze Einheit.

Vanagaudi hat geschrieben:
28 Mär 2020 15:25

Hast du noch eine Übersichtsaufnahme von dem ganzen CD-Spieler, von beiden Seiten? Dann könnte man den Hersteller und den Ersatztyp identifizieren.

Update:
Das könnte ein DVD-Abspieler von Alpine sein, Typ DV43M050, DV43M870, DV43M07B oder DV43M. Wird bei Mercedes NTG2.5 Navigationssysteme eingesetzt. Das Ding kostet aber seine 125 Euro. Die Baueinheit mit dem Laser ED21A710 kostet allerdings nur 15 Euro. Ist also überschaubar.
Ist ein DV43M87 EEK00 00023797 gemäss Typschild. 15€ ist ja okej, dafür würd ich den ganzen Plunder auch wieder auseinanderbauen.
316 NGT, Automatik, Bj. 2011, 9 Sitze, Hochdach

Benutzeravatar
Vanagaudi
Wohnt hier
Wohnt hier
Beiträge: 2960
Registriert: 18 Mai 2013 14:34
Wohnort: Schlootkuhlen

Galerie

Re: SD Karte wird nicht vom APS COMAND gelesen

Beitrag von Vanagaudi »

trcolka hat geschrieben:
28 Mär 2020 18:18
Vanagaudi hat geschrieben:
28 Mär 2020 15:25
Hast du mal ein paar Detailaufnahmen von den Kontaktzungen für den SD-Kartenhalter? Die sind kaum zu erkennen. Sind sie alle gleich hoch?
Die waren alle halbwegs gleich hoch, kommt auf dem Bild nicht so gut rüber. Kontakt sollte da eigentlich bestehen.
Ich weiß nicht, wie du das in Natura siehst, aber mir sieht es so aus, als wenn sich da mal eine SD-Karte verhakt hätte. Die Kontaktoberfläche der Halters sollte eigentlich in etwa parallel zur Kontaktfläche der SD-Karte stehen.
Für (Folge-) Schäden aller Art übernehme ich keine Haftung. Alle einschlägigen (Sicherheits-) Vorschriften sind zu beachten. Im Zweifelsfalle grundsätzlich einen Fachmann fragen bzw. die Arbeiten von einer Fachfirma ausführen lassen.

Benutzeravatar
trcolka
Kennt sich schon aus
Kennt sich schon aus
Beiträge: 58
Registriert: 19 Apr 2019 22:01
Wohnort: Örebro

Fahrerkarte

Re: SD Karte wird nicht vom APS COMAND gelesen

Beitrag von trcolka »

Vanagaudi hat geschrieben:
28 Mär 2020 18:42
Ich weiß nicht, wie du das in Natura siehst, aber mir sieht es so aus, als wenn sich da mal eine SD-Karte verhakt hätte. Die Kontaktoberfläche der Halters sollte eigentlich in etwa parallel zur Kontaktfläche der SD-Karte stehen.
Das ist der erste SD-Kartenleser, den ich mir von innen angucke, ich hab da also nicht so Recht eine Referenz wie das aussehen soll. Die goldenen Kontakthaken sind (soweit ich das beurteilen konnte) an der richtigen Position, um den passenden Kontakt zur SD-Karte zu treffen. Und sie gucken ein wenig nach oben, damit der Kontakt sicher gestellt ist.

Nach dem Einbau hat sich aber leider nichts verändert, Radio erkennt, dass eine Karte eingelegt ist, zeigt aber keinen Inhalt an.
20200328_184636.jpg
20200328_184741.jpg
CD-Spieler ist auch unverändert.

Vor weiteren Reparatur-Versuchen werde ich jetzt erstmal versuchen, das Telefon über Aux anzuschliessen, dazu mache ich aber ein eigenes Thema auf.

Grüsse
Olaf
316 NGT, Automatik, Bj. 2011, 9 Sitze, Hochdach

Antworten